Back to overview
Maintenance

Infrastructure maintenance

May 6, 2026 at 6:30pm UTC  –  May 6, 2026 at 7:00pm UTC
Affected services
Documentation
Platform
API
NemHandel - live
Peppol - live
NemHandel - test
Peppol - test

Resolved
May 6, 2026 at 7:00pm UTC

Maintenance ended

Created
May 6, 2026 at 6:30pm UTC

We're performing upgrades on our infrastructure. The whole platform will be unavailable for a few minutes within the maintenance window.